icon-rss-large

中文泛技术类IT博客 | 留言

软路由 | 硬路由 | 网站地图 |

DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)

发表于 2016年08月28日 软路由版

一、花生壳
花生壳动态域名是全球用户量最大的完全免费的动态域名解析软件(DDNS)。当您安装并注册花生壳动态域名解析软件,无论您在任何地点、任何时间、使用任 何线路,均可利用这一服务建立拥有固定域名和最大自主权的互联网主机。“花生壳动态域名解析软件”支持的线路包括普通电话线、ISDN、ADSL、有线电 视网络、双绞线到户的宽带网和其它任何能够提供互联网真实IP的接入服务线路,而无论连接获得的IP属于动态还是静态。
现在花生壳动态域名解析软件为千万的域名提供动态域名解析服务,并广泛应用于网站建设、视频监控、遥感测绘、FTP、VPN、企业OA、ERP等应用领域。

脚本:

local ipaddr
local server “http://ddns.oray.com
local domain “域名”
local par “/ph/update?&hostname=$domain&myip=$ipaddr”
local users “用户”
local paswd “密码”
:set ipaddr [/ip address get [/ip address find interface=pppoe-out2] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd



二、3322

脚本:


:local ednsuser “用户”
:local ednspass “密码”
:local ednshost “域名”
:local ednsinterface “接口”
:local members “http://members.3322.org/dyndns/update?system=dyndns
#:local members “http://members./nic/update?”
:local status
:local status [/interface get [/interface find name=$ednsinterface] running]
:if ($status!=false) do={
:local ednslastip [:resolve $ednshost]
:if ([ :typeof $ednslastip ] = nil ) do={ :local ednslastip “0” }
:local ednsiph [ /ip address get [/ip address find interface=$ednsinterface ] address ]
:local ednsip [:pick $ednsiph 0 [:find $ednsiph “/”]]
:local ednsstr “&hostname=$ednshost&myip=$ednsip”
:if ($ednslastip != $ednsip) do={/tool fetch url=($members . $ednsstr) mode=http user=$ednsuser password=$ednspass dst-path=$ednshost
:delay 2
:local result [/file get $ednshost contents]
:log info ($ednshost . ” ” .$result)
/file remove $ednshost ;
}
}


本文标题:DDNS动态域名脚本(花生壳+3322公云)for ROS 6.x(转)
本文链接:http://www.kmkad.com/index.php/post/920.html
作者授权:除特别说明外,本文由 citywo 原创编译并授权 大城小我 刊载发布。
版权声明:本文不使用任何协议授权,您可以任何形式自由转载或使用。
0
留言区
留言区

北京快乐8 www.703657.com-陕西派彩走势图| www.257395.com-58彩票网是黑彩吗| www.389263.com-fu福彩试机号| www.600474.com-竞彩让球胜负平| www.739201.com-vip彩票快3-| www.869020.com-彩票3d跨度走势图| 万利www.32123t.com| www.pe73.com-湖北快三11点遗漏| www.48ng.com-彩专家人工计划在线| www.311093.com-惠民彩票犯法嘛| www.201717.cc-彩票购彩大厅| www.333052.com-买彩票窍门-| www.500033.cc-078彩票网址多少| www.639035.com-体彩申请网点| www.785653.com-领航彩下载app| www.916937.com-亚洲彩票快三| www.gn1.com-北京快三撅彩网| www.8fn.com-彩网乐-| www.324378.com-乐彩网是真的吗| www.399318.com-七星彩论坛特区彩| www.507768.com-天马彩票平台怎么样| www.577747.com-昨天的福彩-| www.646869.com-14场胜负彩吧| www.713599.com-傲赢彩票正规吗| www.786185.com-海南彩票梦码| www.862707.com-在网上买彩票犯法吗| www.930329.com-助赢彩票计算器| www.985102.com-福利彩中奖是真的吗| www.kq5.cc-辽宁快三开奖走势图| www.pp84.com-3d彩票分析方法| www.00oy.com-赞美彩虹的诗句李白| www.68zu.com-澳门博彩戒治中心| www.024231.com-福利彩票开奖的结果| www.150791.com-福彩3d选号工具| www.311771.com-河南快三害死人了| www.493049.com-爱彩客彩票-| www.706860.com-87彩店下载-| www.852922.com-中国福彩阳光开奖| www.969033.com-彩53网站多少| www.gf53.com-湖北彩票假球案| www.00rk.com-彩虹周杰伦歌曲下载| www.911.hk-念什么咒语能中彩票| www.09220.com-点彩票二维码| www.89197.com-盈彩彩票注册邀请码| www.110847.com-彩票多久开奖一次| www.243811.com-福彩中心试机号| www.369423.com-体育彩票造假事件| www.526130.com-足球世界杯彩票规则| www.688872.com-真实105彩票| www.818515.com-竞彩图片-| www.946838.com-上海彩钢-| www.yy7.com-福利彩票复式玩法| www.87.net-赢彩彩票怎么提现| www.535.site-彩印门户网站| www.611867.com-附近买彩票的| www.733888.cc-福彩几天开一次奖| www.855535.com-七乐彩复试中奖表| www.963646.com-足彩直播比分直播| www.hc71.cc-乐8网彩票可信吗| www.34op.com-彩运来登录线路检测| www.2887.in-江苏快三如何中奖| www.y97.cc-彩神2官网-| www.98nx.com-竞彩足球合买靠谱吗| www.6235.top-福彩快快乐十分钟| www.16066.cc-彩票双色球怎么玩的| www.57628.com-星彩娱乐是真的吗| www.03ga.com-风之彩app-| www.90ys.com-五分彩五但走势| www.4740.xyz-彩票平台提现不出来| www.372922.com-幸运彩票网网址| www.527090.com-华富鼎博盈彩票被骗| www.679058.com-麒麟彩币最新情况| www.783911.com-广西福令快三| www.887944.com-彩票网站如何推广| www.965065.com-辽宁12选5乐彩网| www.br02.com-魔方彩票是真的吗| www.a04.top-上海快三单双预测| www.54gl.com-毕节福彩中心| www.822329.com-风之彩彩票平台| www.qr61.com-福彩是事业单位么| www.cp9568.com-全民中彩app| www.419.bid-88彩票手机app| www.252862.com-大中华彩票娱乐平台| www.783646.com-爱彩彩票破解器| www.898331.com-今晚六会彩开奖结果| www.926276.com-上饶体彩征召网点| www.252077.com-中彩网违法吗| www.96776.cc-亚博体育假彩票充值| www.202199.com-开奖大全彩票之家| www.984217.com-鸿运彩票app下载| www.si11.com-时时彩预测下期| www.94yr.com-微博不能买彩票了| www.6964.xyz-重庆7时彩正规吗| www.663946.com-nba彩票推荐分析| www.180553.com-五分快三是黑彩吗| www.bo28.com-彩票996-| www.3ta.cc-中福彩票网址| www.243666.cc-下载玩彩app| www.378999.com-3的字谜双彩论坛| www.378367.com-6号彩票app-| www.768875.com-天猫彩票是真的吗| www.904468.com-大发快三下载苹果版| www.336766.cc-江苏快三推荐两不同| www.232790.com-好彩客下载-| www.67895.cc-重庆时时彩黑客名单| www.452345.com-太原福彩店转让| www.295595.com-网络彩票计划师套路| www.76mj.com-九号彩票安装| www.3485.vip-世界杯体彩中奖规则| www.099827.com-福彩三d走势囹| www.908721.com-动物彩票-| www.cai2744.com河北快三走势| www.62922.cc-中国足球彩票开奖| www.63014.com-158彩票官网| 彩之家www.66czj.com| www.644624.com-青岛一等奖彩票排行| www.753938.com-购彩之家我的账户| www.870697.com-如何选择双色球彩票| www.cp6692.com-上海新快三开奖结果| www.89nc.com-彩票站出兑怎么发布| www.271907.com-862彩票-| www.668.online-大乐透走势图众彩网| www.842826.com-中国足彩在线的微博| 十三国际www.592113.com| www.26lh.com-所有快三公式| www.1884.win-彩票3d组选6| www.863113.com-智慧彩走势图| www.651255.com-水彩画大师作品欣赏| www.636358.com-星期六有什么彩票买| www.855413.com-七乐彩奖金有多少| 500万彩票www.39500v.com| www.947132.com-福彩三d字谜开奖号| www.jv77.com-彩铅画人物古风| www.31622.cc-中国竞彩资讯app| www.ha89.com-网上买快三合法吗| www.023910.com-大乐透彩票往期| www.sb15.com-福彩体彩杀号定胆| www.349368.com-合肥福彩中心墩塘| www.962600.com-富贵彩平台怎么下载| www.43336.com-旺彩四肖中特图片| www.ab23.com-多乐彩开奖结果| www.067578.com-凤凰娱乐彩票可信吗| www.k29.net-福彩3d表-| www.16574.com-网上去哪买体彩| www.571018.com-查彩票中奖-| www.898978.com-大发快三注册送彩金| 金彩www.985jc.com| www.8731.cc-竞彩推单哪个靠谱| www.544467.com-彩票网站告别死工资| www.682393.com-网上买足彩app| www.lz97.com-3分彩真的假的| www.054501.com-福利彩票平台出租| www.28476.com-888彩票真的吗| www.113344.cc-明代红绿彩拍卖| www.304077.com-9cb彩票计划网址| www.ss42.com-时时彩五星做号技巧| www.8973.cn-关于国彩-| www.233106.com-足彩新浪彩票| www.63010.com-新疆福彩时彩开奖| www.199175.com-快三助手软件下载| www.881985.com-01彩票违法| www.125621.com-盛世彩票官网平台| www.74ea.com-福彩500开奖| www.455512.com-网络彩票真假问题|